$re = '/\s(http[^\s]+)/i';
$str = 'href="http.some.com"
http.
My link is at http:google.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;