re = /\s(http[^\s]+)/i
str = 'href="http.some.com"
http.
My link is at http:google.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result