use strict;
my $str = 'href="http.some.com"
http.
My link is at http:google.com';
my $regex = qr/\s(http[^\s]+)/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";