package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s(http[^\s]+)`)
var str = `href="http.some.com"
http.
My link is at http:google.com`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}