const regex = /\s(http[^\s]+)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(http[^\\s]+)', 'ig')
const str = `href="http.some.com"
http.
My link is at http:google.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);