#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)"
Local $sString = "java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>" & @CRLF & _
"java.util.Map<java.util.List<String>, java.lang.Object>, Object" & @CRLF & _
"java.util.List<String>, java.lang.Object" & @CRLF & _
"java.util.List<String>" & @CRLF & _
"java.lang.Object"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")