import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<argument>\\w+(?:\\.\\w+)*(?:\\<(?<arglist>\\g<argument>(?:,\\s\\g<argument>)*)\\>)?)";
final String string = "java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>\n"
+ "java.util.Map<java.util.List<String>, java.lang.Object>, Object\n"
+ "java.util.List<String>, java.lang.Object\n"
+ "java.util.List<String>\n"
+ "java.lang.Object";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}