re = /(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)/
str = 'java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>
java.util.Map<java.util.List<String>, java.lang.Object>, Object
java.util.List<String>, java.lang.Object
java.util.List<String>
java.lang.Object'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end