package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)`)
var str = `java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>
java.util.Map<java.util.List<String>, java.lang.Object>, Object
java.util.List<String>, java.lang.Object
java.util.List<String>
java.lang.Object`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}