const regex = /(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<argument>\\w+(?:\\.\\w+)*(?:\\<(?<arglist>\\g<argument>(?:,\\s\\g<argument>)*)\\>)?)', 'g')
const str = `java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>
java.util.Map<java.util.List<String>, java.lang.Object>, Object
java.util.List<String>, java.lang.Object
java.util.List<String>
java.lang.Object`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}