import Foundation
let pattern = #"(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>
java.util.Map<java.util.List<String>, java.lang.Object>, Object
java.util.List<String>, java.lang.Object
java.util.List<String>
java.lang.Object
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)