$re = '/(?<argument>\w+(?:\.\w+)*(?:\<(?<arglist>\g<argument>(?:,\s\g<argument>)*)\>)?)/';
$str = 'java.util.Map<java.util.Map<java.util.List<String>, java.lang.Object>, Object>
java.util.Map<java.util.List<String>, java.lang.Object>, Object
java.util.List<String>, java.lang.Object
java.util.List<String>
java.lang.Object';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);