# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{9})(.)(.)(.*)$/$1$3$2$4/gm;t' <<< "34gf7asjkabaa4sfdlencxnkil9qrx"