use strict;
my $str = '34gf7asjkabaa4sfdlencxnkil9qrx';
my $regex = qr/^(.{9})(.)(.)(.*)$/mp;
my $subst = '$1$3$2$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";