package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.{9})(.)(.)(.*)$`)
var str = `34gf7asjkabaa4sfdlencxnkil9qrx`
var substitution = "$1$3$2$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}