import Foundation
let pattern = #"^(.{9})(.)(.)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"34gf7asjkabaa4sfdlencxnkil9qrx"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$2$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)