// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.{9})(.)(.)(.*)$").unwrap();
let string = "34gf7asjkabaa4sfdlencxnkil9qrx";
let substitution = "$1$3$2$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}