# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/quick.*?\Kslug crawls under/fox jumps over/;t' <<< "The quick brown slug crawls under the lazy dog."