import Foundation
let pattern = #"quick.*?\Kslug crawls under"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The quick brown slug crawls under the lazy dog."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"fox jumps over"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}