use strict;
my $str = 'The quick brown slug crawls under the lazy dog.';
my $regex = qr/quick.*?\Kslug crawls under/p;
my $subst = 'fox jumps over';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";