const regex = /quick.*?\Kslug crawls under/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('quick.*?\\Kslug crawls under', '')
const str = `The quick brown slug crawls under the lazy dog.`;
const subst = `fox jumps over`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);