using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"quick.*?\Kslug crawls under";
string substitution = @"fox jumps over";
string input = @"The quick brown slug crawls under the lazy dog.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}