re = /quick.*?\Kslug crawls under/
str = 'The quick brown slug crawls under the lazy dog.'
subst = 'fox jumps over'
result = str.sub(re, subst)
# Print the result of the substitution
puts result