# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\\.sp (\d+)?\\/\n\n\n\n\n/gm;t' <<< "This is result level note five: This text is highlighted\.sp 5\This sentence should be displayed after 5 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
This is result level note without a number: This text is highlighted\.sp \This sentence should be displayed after 1 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
"