import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\\\.sp (\\d+)?\\\\";
final String string = "This is result level note five: This text is highlighted\\.sp 5\\This sentence should be displayed after 5 new lines.\\.ce\\This line should be centered.\n"
+ "This sentence should be on a new line.\n\n"
+ "This is result level note without a number: This text is highlighted\\.sp \\This sentence should be displayed after 1 new lines.\\.ce\\This line should be centered.\n"
+ "This sentence should be on a new line.\n";
final String subst = "\\n\\n\\n\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}