#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\\\.sp (\d+)?\\"
Local $sString = "This is result level note five: This text is highlighted\.sp 5\This sentence should be displayed after 5 new lines.\.ce\This line should be centered." & @CRLF & _
"This sentence should be on a new line." & @CRLF & _
"" & @CRLF & _
"This is result level note without a number: This text is highlighted\.sp \This sentence should be displayed after 1 new lines.\.ce\This line should be centered." & @CRLF & _
"This sentence should be on a new line." & @CRLF & _
""
Local $sSubst = "\n\n\n\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)