import Foundation
let pattern = #"\\\.sp (\d+)?\\"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is result level note five: This text is highlighted\.sp 5\This sentence should be displayed after 5 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
This is result level note without a number: This text is highlighted\.sp \This sentence should be displayed after 1 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\n\n\n\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)