const regex = /\\\.sp (\d+)?\\/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\\\.sp (\\d+)?\\\\', 'gm')
const str = `This is result level note five: This text is highlighted\\.sp 5\\This sentence should be displayed after 5 new lines.\\.ce\\This line should be centered.
This sentence should be on a new line.
This is result level note without a number: This text is highlighted\\.sp \\This sentence should be displayed after 1 new lines.\\.ce\\This line should be centered.
This sentence should be on a new line.
`;
const subst = `\n\n\n\n\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);