$re = '/\\\\\.sp (\d+)?\\\\/m';
$str = 'This is result level note five: This text is highlighted\\.sp 5\\This sentence should be displayed after 5 new lines.\\.ce\\This line should be centered.
This sentence should be on a new line.
This is result level note without a number: This text is highlighted\\.sp \\This sentence should be displayed after 1 new lines.\\.ce\\This line should be centered.
This sentence should be on a new line.
';
$subst = "\n\n\n\n\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;