package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\.sp (\d+)?\\`)
var str = `This is result level note five: This text is highlighted\.sp 5\This sentence should be displayed after 5 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
This is result level note without a number: This text is highlighted\.sp \This sentence should be displayed after 1 new lines.\.ce\This line should be centered.
This sentence should be on a new line.
`
var substitution = "\n\n\n\n\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}