const regex = /t/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('t', 'gm')
const str = `// 提取金额
v me \$50
v me \$1.5
v me \$-50
// 只匹配上面的金额
---分割线---
v me \$1.
v me \$.5
v me \$.22
v me \$22.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}