re = /t/m
str = '// 提取金额
v me $50
v me $1.5
v me $-50
// 只匹配上面的金额
---分割线---
v me $1.
v me $.5
v me $.22
v me $22.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end