// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)t").unwrap();
let string = "// 提取金额
v me $50
v me $1.5
v me $-50
// 只匹配上面的金额
---分割线---
v me $1.
v me $.5
v me $.22
v me $22.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}