import re
regex = re.compile(r"t", flags=re.MULTILINE)
test_str = ("// 提取金额\n"
"v me $50\n"
"v me $1.5\n"
"v me $-50\n"
" \n"
"// 只匹配上面的金额\n"
"---分割线---\n"
" \n"
"v me $1. \n"
"v me $.5\n"
"v me $.22\n"
"v me $22.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")