# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/( *)("Description".*?CCGcode.*?<td>)([^<]+)/\1"CCGcode": "\3",\n\1\2/;t' <<< "\"properties\": {
\"Name\": \"Darlington\",
\"Description\": \"<br><br><br> <table border=\\"1\\" padding=\\"0\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>\"
}"