const regex = /( *)("Description".*?CCGcode.*?<td>)([^<]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( *)("Description".*?CCGcode.*?<td>)([^<]+)', '')
const str = `"properties": {
"Name": "Darlington",
"Description": "<br><br><br> <table border=\\"1\\" padding=\\"0\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>"
}`;
const subst = `\1"CCGcode": "\3",\n\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);