import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( *)(\"Description\".*?CCGcode.*?<td>)([^<]+)";
final String string = "\"properties\": {\n"
+ " \"Name\": \"Darlington\",\n"
+ " \"Description\": \"<br><br><br> <table border=\\\"1\\\" padding=\\\"0\\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>\"\n"
+ "}";
final String subst = "\\1\"CCGcode\": \"\\3\",\\n\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}