use strict;
my $str = '"properties": {
"Name": "Darlington",
"Description": "<br><br><br> <table border=\\"1\\" padding=\\"0\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>"
}';
my $regex = qr/( *)("Description".*?CCGcode.*?<td>)([^<]+)/p;
my $subst = '\\1"CCGcode": "\\3",\\n\\1\\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";