re = /( *)("Description".*?CCGcode.*?<td>)([^<]+)/
str = '"properties": {
"Name": "Darlington",
"Description": "<br><br><br> <table border=\\"1\\" padding=\\"0\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>"
}'
subst = '\\1"CCGcode": "\\3",\\n\\1\\2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result