import re
regex = re.compile(r"( *)(\"Description\".*?CCGcode.*?<td>)([^<]+)")
test_str = ("\"properties\": {\n"
" \"Name\": \"Darlington\",\n"
" \"Description\": \"<br><br><br> <table border=\\\"1\\\" padding=\\\"0\\\"> <tr><td>CCGcode</td><td>00C</td></tr> <tr><td>CCGname_short</td><td>Darlington</td></tr>\"\n"
"}")
subst = "\\1\"CCGcode\": \"\\3\",\\n\\1\\2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)