# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+/ /g;t' <<< "This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex"