using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+";
string substitution = @" ";
string input = @"This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}