use strict;
my $str = 'This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex';
my $regex = qr/(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";