const regex = /(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?::keyword_start:|\\G(?!^)\\S+)\\K(?<!_end:)\\s+', 'g')
const str = `This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);