package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((^)|(\<\/table\>))(.*?)((\<table\>)|($))`)
var str = `dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa`
var substitution = "\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}