import re
regex = re.compile(r"((^)|(\<\/table\>))(.*?)((\<table\>)|($))")
test_str = "dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa"
subst = "\\4"
result = regex.sub(subst, test_str)
if result:
print(result)