import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^)|(\\<\\/table\\>))(.*?)((\\<table\\>)|($))";
final String string = "dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa";
final String subst = "\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}