#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(resume|posting) (\d+)(?:.*?in ([\d.]+) secs)?"
Local $sString = "Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs" & @CRLF & _
"Created posting 187294183"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")