re = /(resume|posting) (\d+)(?:.*?in ([\d.]+) secs)?/m
str = 'Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs
Created posting 187294183'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end