using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(resume|posting) (\d+)(?:.*?in ([\d.]+) secs)?";
string input = @"Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs
Created posting 187294183";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}